O programie

Program RAAP - Rejestracja i Analiza Agregacji Płytek
(Wymagania na sprzęt i system operacyjny: dowolny komputer PC posiadający interfejs USB, system Win95 druga edycja lub wyższy)

Autorzy:

prof. Dr hab. Barbara Kostka
Zakład Biochemii Farmaceutycznej
Uniwersytet Medyczny w Łodzi

mgr inż. Zbigniew Lipiński
 Firma ZL, Łódź

Kontakt

Zagadnienia biochemiczne oraz dystrybucja programu:
Dr. Jacek Golański
Zakład Zaburzeń Krzepnięcia Krwi Katedry Diagnostyki Laboratoryjnej
Uniwersytet Medyczny w Łodzi
tel. (0-42) 678-75-67
e-mail: jgolansk@toya.net.pl

Zagadnienia biochemiczne:
prof. Dr hab. Barbara Kostka
Zakład Biochemii Farmaceutycznej
Uniwersytet Medyczny w Łodzi
tel. (0-42) 677-91-31
e-mail: bkostka@pharm.am.lodz.pl

Sprawy techniczne:
mgr inż. Zbigniew Lipiński
 Firma ZL , ul. Muszyńskiego 1, Łódź
tel. (0-42) 677-92-92
e-mail: info@firmazl.pl


Program RAAP - Rejestracja i Analiza Agregacji Płytek
Opis ogólny

czytaj dalej

Rys 1. Widok głównego okna programu

Program wraz z wchodzącym w skład zestawu przetwornikiem analogowo-cyfrowym wypełnia następujące funkcje:

Funkcje rejestracji:

  • Rejestracja agregacji w funkcji czasu w dwóch kanałach jednocześnie z częstotliwością próbkowania 30 próbek/s
    Mksymalny czas trwania pojedynczego pomiaru wynosi 30 min.

Funkcje archiwizacji i wizualizacji pomiarów:

  • Zapis na dysku i odczyt krzywych agregacji wraz z ich opisami

  • Uwidocznienie w jednym oknie (ekranie) do czterech krzywych jednocześnie w celu ich porównania

  • Zmiana skali krzywych w osiach X i Y

  • Zapis i odczyt kompletnych ekranów wraz z opisami

  • Wydruk ekranów (zawierających od jedniej do czterech krzywych)

  • Kopiowanie ekranów do schowka w celu wklejenia ich do innych dokumentów, np. tekstowych lub graficznych.

Funkcje analizy krzywych

  • Automatyczne obliczenia parametrów krzywej

  • Ręczny pomiar parametrów krzywej

Funkcje eksportu danych:

  • Import krzywych z pliku tekstowego

  • Eksport krzywych do pliku tekstowego

  • Eksport obliczonych wyników do pliku tekstowego


Praca z agregometrem APACT

Podłączenie do komputera .
 Włączenie i kalibracja .
 Pomiary .

Podłączenie agregometru APACT do komputera

Agregometr ma na tylnej ściance dwa gniazda: 25 i 15 pinowe. Gniazdo 25 pinowe łączymy poprzez kabel RS232 (tzw. kabel do modemu) z portem COM komputera. Do gniazda 15 pinowego należy włożyć wtyczkę, w której zwarte są końcówki 1 i 10 (chyba, że do gniazda tego podłączony jest ploter)
W programie należy:
1. W oknie głównym ustawić "Urządzenie" na "Agregometr APACT"
2. Otworzyć okno konfiguracji, ustawić numer portu COM (zgodnie z numerem portu do którego został podłączony agregometr) i kliknąć klawisz "Połącz".
Program zapamiętuje ustawienia tak, że w.w. czynności nie trzeba powtarzać po jego ponownym uruchomieniu.

Włączenie i kalibracja.

1.Włączamy komputer.
2.Włączamy agregometr
3.Po ustaniu sygnału dźwiękowego agregometr rozpoczyna autotest. Można go przerwać naciskając dowolny klawisz na klawiaturze foliowej urządzenia.
4.Migają diocy kanałów (CH1 i CH2). Wybieramy kanał 1.
5.Wkładamy próbkę z osoczem PPP i naciskamy przycisk PPP
6.Powtarzamy punkty 4 i 5 dla kanału 2.

Pomiary
1.Uruchamiamy program.
2.Klikamy w przycisk "Gotowość":

3.Na agregometrze wybieramy kan.1. Wkładamy próbkę, naciskamy przycisk PRP, a następnie START.
W tym pomencie na ekranie komputera powinien automatycznie zostać "wciśnięty" przycik "Przesuw papieru":

4. W czasie, gdy trwa rejestracja, możemy powtórzyć punkt 3 dla drugiego kanału.

5. Po zakończeniu rejestracji naciskamy przycisk "Stop" na klawiaturze foliowej (przedtem wybierając kanał, w którym chcemy przerwać rejestrację). Alternatywnie można ustawić wcześniej czas rejestracji naciskając przycisk "Stop" i wprowadzając z numerycznej klawiatury foliowej żądany czas w minutach.
Gdy zakończona zostanie rejestracja w obu kanałach, program samoczynnie przejdzie w tryb przeglądu krzywych.

6. Następny cykl pomiarowy rozpoczynamu od p. 2
Uwaga: przed rozpoczęciem kolejnego cyklu rejestracji należy zapisać pomierzone krzywe.


Parametry krzywej obliczane automatycznie

Parametry automatycznie obliczane przez program

Rys.1 - Parametry automatycznie obliczane przez program

Program może obliczać automatycznie następujące parametry krzywej agregacji:

Parametr | Opis
A6Min | Wartość agregacji względem linii podstawowej po upływie 6 minut od dodania agonisty. (Parametr ten nie jest uwidoczniony na rys.1). Parmetr ten został wprowadzony w celu umożliwienia porównania wyników z odczytem ze starszych typów agregometrów, wyświetlających właśnie tę wartość.
Amax | Maksymalna warość agregacji
ZK | Zmiana kształtu. Obniżenie krzywej agregacji poniżej linii podstawowej po dodaniu agonisty
DA | Wartość dezagregacji (względem agregacji maksymalnej)
Td | Czas późnienia (d &ndash delay) &ndash czas od dodania agonisty do osiągnięcia 10% agregacji maksymalnej
Tr | Czas narastania (r &ndash rise) &ndash czas pomiedzy punkatami, w których krzywa osiąga 10% Amax i 90%AMax
Tc | Czas trwania plateau (c &ndash constant) &ndash czas pomiędzy punktem 90%AMax na zboczu narastającym i 90% na zboczu opadającym (względem prawej linii podstawowej)
Tf | Czas opadania krzywej &ndash czas pomiedzy punktami 90% i 10% wysokości opadającego zbocza krzywej
V0r | Maksymalna prędkość narastania krzywej
Vavgr | Średnia prędkość narastania krzywej
V0f | Maksymalna prędkość opadania krzywej
Vavgf | Średnia prędkość opadania krzywej (parametr nie uwidoczniony na rys1) Jest zdefiniowany jako średnia prędkość narastania od 10% do 90% wysokości zbocza narastającego: Vavgf = (90%Amax-10%Amax)/Tr
AUCr | Powierzchnia pola pod narastającą częścią krzywej. (zobacz też: pola obliczane przez program )
AUCc | Powierzchnia pola pod plateau (zobacz też: pola obliczane przez program )
AUCf | Powierchnia pola pod opadającą częścią krzywej (zobacz też: pola obliczane przez program )
AUC | Pole pod krzywą: AUC = AUCr+AUCc+AUCf (zobacz też: pola obliczane przez program )

Poprawne obliczenie powyższych parametrów jest uzależnione od rozpoznania na krzywej pewnych charakterystycznych miejsc i ustawienia w nich odpowiednich znaczników . Przy obliczeniach automatycznych program sam rozpoznaje te miejsca. Jednak ponieważ w przypadku krzywych zaszumionych lub o nietypowym przebiegu procedury rozpoznawania automatycznego mogą zawodzić, możliwe jest ich wyłaczenie dla dowolnego znacznika (znaczników).
Listę znaczników ustawianych przy obliczeniach automatycznych można zobaczyć tutaj.

W przypadku, gdy zachodzi potrzeba obliczenia innych parametrów, niż ujęte w powyższej tabeli, można posłużyć się jednym z dwóch sposobów pomiarów ręcznych.


Znaczniki ustawiane na krzywej przy obliczeniach automatycznych

Miejsca na krzywej, w których ustawiane są znaczniki , przy automatycznym obliczaniu parametrów .

Nr | Opis
1 | Linia podstawowa
2 | Moment dodania agonisty
3 | Maksimum zmiany kształtu
4 | Punkt, w którym agregacja osiąga 10% agregacji maksymalnej (Amax)
5 | Miejsce najszybszego narastania agregacji.
6 | Punkt, w którym agregacja osiąga 90% agregacji maksymalnej (Amax)
7 | Maksimum agregacji
8 | Miejsce na opadającym zboczu krzywej, w którym agragacja wynosi 90% agregacji maksymalnej (względem prawej linii odniesienia).
9 | Miejsce najszybszego opadania agregacji
10 | Miejsce na opadającym zboczu krzywej, w którym agragacja wynosi 10% agregacji maksymalnej (względem prawej linii odniesienia)
11 | Punkt dezagregacji. Program umożliwia ustawianie tego znacznika w określonej odległości (na osi czasu) od punktu dodania agonisty, lub też wg kryterium nachylenia krzywej (jeżeli prędkość opadania krzywej maleje poniżej zadanego procentu średniej prędkości narastania)


Obliczenia ręczne

Pomiary ręczne

Obok obliczeń automatycznych program oferuje także możliwość ręcznych pomiarów krzywej. Stosuje się je w przypadku konieczności policzenia parametrów, które nie są obliczane automatycznie lub w przypadku krzywych o nietypowym przebiegu, gdzie obliczenia automatyczne zawodzą.
Ręczne pomiary parametrów umożliwiają także wykorzystanie programu do analizy zjawisk innych, niz agregacja płytek krwi.

Pomiary ręczne można wykonywać na dwa różne sposoby, posługując się różnymi zakładkami w oknie obliczeń:

Okno obliczeń ręcznych
zakładka "Obl. ręczne"

 Otwarcie okna obliczeń ręcznych (po lewej) powoduje, ze w oknie głównym zostają wyświetlone cztery znaczniki. Znaczniki 1 i 2 wyznaczają na krzywej punkty odniesienia (odpowiednio na osiach X i Y). Znacznik 4 jest znacznikiem pomiarowym. Znacznik 3 stosuje się do wyznaczenia obliczanego pola pod krzywą.
Wszystkie znaczniki można przemieszczać za pomocą myszy, zaś znaczniki 3 i 4 mogą też być ustawiane w punktach krzywej, których współrzędne X lub Y różnią się o określoną wartość od współrzędnych punktów wyznaczonych znacznikami odniesienia.

Okno obliczeń ręcznych wyświetla następujące parametry:
  • Różnicę współrzędnych X znaczników 4 i 2 (w jednostkach czasu)
  • Różnicę współrzędnych Y znaczników 4 i 1 (w jednostakach osi Y ustalonych przy konfiguracji programu)
  • Powierzchnię pola ograniczonego od góry mierzaną krzywą, od dołu linią odniesienia, (wyznaczoną przez znacznik 1), od lewej znacznikiem 3 i od prawej znacznikiem 4.

Okno obliczeń ręcznych
zakładka "Znaczn."

 Zakładka "Znaczn." umożliwia odczyt różnicy współrzędnych na osi czasu i osi Y między parami punktów wyznaczonych przez dowolnie wybrane znaczniki.


Przykładowa analiza - krok po kroku

Przykładowa analiza krzywej - krok po kroku

1. W oknie głównym kliknij klawisz "Otwórz krzywą"

2. W dialogu otwierania krzywej pomiaru zaznacz plik "Agregacja.POM" i kliknij przycisk "Otwórz".
Na ekranie okna głównego powinna pojawić się krzywa agragacji.

3. W oknie głównym kliknij przycisk "Obliczenia". Otworzy się dialog obliczeń
(Po otwarciu dialogu obliczeń kursor na pewien czas zmieni się ze strzałki na klepsydrę. Program oblicza wtedy krzywą uśrednioną. Po zakończeniu obliczeń krzywa uśredniona (w kolorze czarnym) jest wyświetlana na ekranie.)

4. Po otwarciu dialogu obliczeń aktywna będzie zakładka "Oblicz param" umozliwiająca określenie, które parametry chcemy obliczać.

Bez wprowadzania zmian przechodzimy do zakładki obliczeń automatycznych
5. Klikamy w przycisk automatycznego ustawienia znaczników .

6. Otworzy się okno umożliwiające wyłączenie procedur automatycznego ustawiania dla dowolnego znacznika.
Nie wprowadzając zmian klikamy OK. Znaczniki w oknie głównym zostaną ustawione w charakterystycznych punktach krzywej.

7. Kliknij przycisk "Oblicz" Wyniki zostaną wpisane do okna obliczeń. Mozna też je skopiować do schowka Windows (w formacie umożliwiającym bezpośrednie wklejenie do arkusza kalkulacyjnego MS Excel), a także dodać do opisu krzywej przy zapisywaniu jej na dysk.

Gratulacje, właśnie przeanalizowałeś przykladową krzywą.
Teraz możesz zapoznać się z pozostałymi funkcjami programu.

Pomocne będą w tym podpowiedzi ukazujące się po dłuzszym przytrzymaniu kursora myszy nad wybranym elementem programu :


Strona bez nazwy

Eksport i import krzywych

Czasami zachodzi potrzeba wymiany danych z innymi programami, np. z arkuszami kalkulacyjnymi (np.Excel).
Dla jej umożliwienia wprowadzono możliwość eksportu i imprortu krzywych do/z pliku tekstowego.

Rys. 1.
Przyciski eksportu i importu krzywych

1. Eksport.

Kliknięcie w przycisk eksportu powoduje otwarcie okna przedstawionego na rys. 2.

Rys.2.
Okno eksportu krzywych.

Jednorazowo eksportowana jest tylko jedna krzywa. Wybieramy ja przełącznikiem "Krzywa" w lewej dolnej części okna. Okno umożliwia także określenie ile próbek na każdą sekundę pomiaru zostanie zapisanych w pliku tekstowym. Program pamieta 30 próbek/sek, ale zapisany z taką gęstością plik tekstowy składałby się z 18 tysięcy linii na każde 10 min. pomiaru! Dlatego zwykle wybieramy mniejszą gęstość zapisu, pamiętając jednak, by była ona wystarczająco duża by nie zniekształcić szybko zachodzących zmian wartości mierzonej .Zgodnie z twierdzeniem Shanona-Kotielnikowa o próbkowaniu częstotliwość próbek musi być co najmniej dwukrotnie większa od najwyższej częstotliwości w widmie próbkowanego przebiegu. Ponieważ jednak w tym przypadku dysponujemy zapisem przebiegu w dziedzinie czasu, a nie częstotliwości, musimy zwracać uwagę na stromość zboczy i tak dobierać częstotliwość próbek, by na najstromsze zbocze przypadały co najmniej dwie-trzy próbki.

Zapisywany plik tekstowy składa się z dwóch kolumn, z których pierwsza podaje czas od początku pomiaru, zaś druga - mierzoną wartość, np:
Kolumny oddzielone są znakami tabulacji. Jako separator dziesiętny służy przecinek.

2. Import.

Kliknięcie w przycisk importu otwiera okno pokazane na rys.3.

Rys.3.
Okno importu krzywych

Zawiera ono następujące elementy:

- Przełączniki "Importuj" umozliwiające wybór krzywych do zaimportowania Program może importować kilka krzywych w jednego pliku tekstowego, o ile ten ostatni zawiera odpowiednią ilośc kolumn. Aktywne są tylko przełączniki odpowiadające krzywym, dla których plik tekstowy zawiera dane.

- Przełacznik "Separator dziesiętny". Należy ustawić taki separator (przecinek lub kropkę), jaki był użyty w pliku źródłowym.

- Przełącznik "Pomnóż przez" umożliwia ustawienie liczby, przez którą będą mnożone odczytane wartości.

- Przełącznik "Odwróć" - gdy jest zaznaczony, otrzymane wartości są dodatkowo mnożone przez -1

- Przełącznik "Czas pomiaru" - jeżeli w pliku tekstowym nie jest zapisany czas pobierania próbek (por. następny punkt), musimy poinformować program, jak długo trwał pomiar przy pomocy tego przełącznika (można używać strzałek lub wpisać wartość).

- Przełącznik "Czas w 1 kol" - zaznaczamy go, gdy pierwsza kolumna pliku tekstowego zawiera czasy pobierania poszczególnych próbek (jak ma to miejsce np. w przypadku plików wyeksportowanych z programu RAAP). Gdy pole nie jest zaznaczone, program interpretuje pierwszą kolumnę pliku tekstowego jako wartości próbek krzywej nr1.

Format pliku tekstowego przeznaczonego do zaimportowania.
Program dopuszcza kilka wariantów formatu pliku źródłowego. Obowiązują następujące reguły:
- Kolumn może być od 1 do 4. (Do 5 jeżeli w pierwszej kolumnie są czasy pobierania próbek)
- Każda kolumna zawiara wartości dla jednej krzywej. Ponadto pierwsza kolumna może zawierać czas pobierania próbek (w sekundach licząc od początku pomiaru)
- Jezeli początkowe wiersze nie daja się zinterpretować jako liczby, są one dołączane do opisu krzywej (kolumny mogą więc mieć nagłówki)
- Ew. wiersze nie dające się przekształcić na liczbę występujące w środku kolumny (po pierwszej liczbie) są traktowane jako błąd.
- Kolumny muszą mieć tę samą ilość wierszy opisowych (wierszy nagłówka).
- Kolumny są rozdzielane znakami TAB lub co najmniej dwoma spacjami.


Eksport obliczonych parametrów

Rys.1.
Okno obliczeń. Zaznaczono przyciski służące do eksportu parametrów.

Do eksportu obliczonych parametrów służą dwa przyciski w oknie obliczeń, uwidocznione na rys.1. Pierwszy z nich kopiuje do schowka systemowego dwie linie tekstu: pierwsza zawiera nazwy obliczanych parametrów, a druga - ich jednostki. Drugi przycisk kopiuje wartosci parametrów. Możemy zatem utworzyć plik zawierający wyniki całej serii pomiarów. Aby to uczynić, należy:

1. Otworzyć dowolny edytor tekstowy, n.p. notatnik.
2. Obliczyc parametry pierwszej z mierzonych krzywych.
3. W oknie obliczeń programu RAAP kliknąć przycisk kopiujący nagłówki parametrów i jednostki.
4. W edytorze tekstowym nacisnąć <ctrl>V lub wybrać Edycja/Wklej. Spowoduje to przepisanie zawartości schowka do edytowanego pliku.
5. Skopiować do schowka wyniki obliczeń przy pomocy prawego przycisku
6. Wkleić wyniki do edytora.

Punkty 5 i 6 można powtarzać dla następnych krzywych. Powyższy opis jest nieco skomplikowany, ale w praktyce omawiane czynności zabierają znacznie mniej czasu, niż czytanie o nich i nie są uciążliwe. Taki sposób eksportu parametrów umożliwia za to dowolne kształtowanie pliku tekstowego; może to być np. plik przeznaczony do wczytania przez arkusz kalkulacyjny, lub też artykuł do którego wstawiamy obliczone wyniki.

Pamiętać jedynia należy, że wklejane parametry są oddzielone zawsze pojedynczym znakiem tabulacji. Jeżeli w edytorze odległość między punktami tabulacji będzie mniejsza, niż szerokość napisu w danej kolumnie, konieczna będzie ręczna korekta tekstu przez wstawienie dodatkowych znaków TAB lub korektę położenia punktów tabulacji.


Główne okno programu

Rys.1. Okno główne programu


Pola pod krzywą obliczane przez program

Pola obliczane przez program

AUCr - Pole pod narastającą częścią krzywej
AUCc - Pole pod górnym plateau
AUCf - Pole pod opadającą częścią krzywej

Pole pod krzywą: AUC = AUCr+AUCc+AUCf


Znaczniki - co to jest?

Znaczniki

Znaczniki są to pionowe linie wskazujące charakterystyczne miejsca na krzywej. Można je przesuwać za pomocą myszy.

Przy obliczeniach automatycznych program sam umieszcza w odpowiednich punktach krzywej znaczniki niezbędne do obliczenia paramertów agregacji. Jednak ze względu na to, że w przypadku krzywych zaszumionych lub o nietypowym przebiegu procedury rozpoznawania punktów charakterystycznych mogą nie działać poprawnie, istnieje możliwość ich wyłączenia dla dowolnych znaczników.